System Requirements

Axialis IconWorkshop™ has been designed to work with Windows 2000, Windows® XP, Windows® Server 2003, Windows Vista™.

Minimum

Recommended